Installation Guide

Downloads

Installing

Install the latest version from the Python Package Index using pip (which comes with the default installation of Python) from the command line by executing:

pip install FoxDot

Alternatively, you can build from the source on GitHub:

git clone https://github.com/Qirky/FoxDot.git
cd FoxDot
python setup.py install

Open SuperCollder and install the FoxDot and BatLib Quarks (this allows FoxDot to communicate with SuperCollider – requires Git to be installed on your machine) by entering the following and pressing Ctrl+Return:

Quarks.install("FoxDot")

Recompile the SuperCollider class library by going to Language -> Recompile Class Library or pressing Ctrl+Shift+L. If you don’t have Git installed, you can download an install the necessary SuperCollider Quarks directly by running the 2 lines of code below in SuperCollider:

Quarks.install("https://github.com/Qirky/FoxDotQuark.git")
Quarks.install("https://github.com/supercollider-quarks/BatLib.git")

Startup

Open SuperCollider and evaluate the following:

FoxDot.start

SuperCollider is now listening for messages from FoxDot. To start FoxDot from the command line (command prompt in Windows, terminal in MacOS or Linux), just type:

python -m FoxDot

The FoxDot interface should open up and you’re ready to start jamming! Check out the starter guide for some useful tips on getting to know the basics of FoxDot. Happy coding!


Please report any issues or bugs on the project’s GitHub or if you have any questions, feel free to leave a message on the discussion forum.